Author Topic: Fix for Saitek stick problems!  (Read 480 times)

Offline AKA_Ramstein

  • "Sir! We're surrounded!" - "Excellent! We can shoot in any direction!"
  • Administrator
  • Hero Member
  • *****
  • Posts: 1651
    • View Profile
Fix for Saitek stick problems!
« on: October 14, 2014, 08:47:02 pm »
I had a big problem with my Saitek stick not launching weapons properly, especially in DCS...

I fixed it by doing this (apparently, Saitek joysticks do not play nice with TeamSpeak):
http://forums.eagle.ru/showthread.php?t=122307&highlight=launch

Quote
Quote:
Originally Posted by Raven434th View Post
Saw this at simhq posted by woofiedog:

Trying to pin down some issues with the rhino, could people please post any issues you have with the X-55 as well as your system specs.

some issues I've noticed so far:

1. Multiple button presses being fired when running TeamSpeak 3(confirmed by mad catz tech support).To replicate this just run TS and open the test page and press a programmed button. The joy button must be programmed with a key press

2. Ghost button presses...this occurs when sliding the throttle back and forth and causes random button presses. This can be observed in the programming window without programmed buttons.It may take a few tries of sliding the throttle at varying speeds to see this issue. I've tried this on 3 different computers with 2 different rhinos and get the ghosting to different degrees. The only thing I can see in common in my case is AMD cpu chip sets on windows 7 64 bit.

Open TS window and click on Settings/Options/Hotkeys and in the drop down menu (lower right corner) select Keyboard and Mouse Only.
__________________

ASUS Z107 Pro Gaming
Intel i53570K 3.40 GHZ
G.Skill DDR4 ram 16 GB
Nvidia GTX1060 6GB Video Graphics
WD Black WD1002FAAEX 1TB
46" Samsung HDTV
Win10 pro x64
Silicon Power 240GB M55 M.2 2280 SSD
Saitek X52 Pro HOTAS, CH Pedals
CM HAF 922 pc case